KiCad向けLeafonyテンプレートを使うと、Leafony busの接続部や基板外形を設定した状態から拡張リーフの設計を始められます。回路図、PCB、専用のシンボル・フットプリント、層構成、デザインルールを収録しています。
このページは、GitHubのKiCadテンプレートREADMEに基づく設定・利用手順です。

- KiCad 10.0系
- KiCadの標準シンボル・フットプリントライブラリ
KiCadの初回起動時は標準ライブラリを使用する設定を選びます。Linuxなどでライブラリが別パッケージの場合は、標準ライブラリもインストールしてください。回路図の電源シンボルは標準の power ライブラリを参照します。
ダウンロード
Section titled “ダウンロード”GitHub - leafony/cad-templateで Code → Download ZIP を選び、ZIPを展開します。Gitを使用する場合は、次のコマンドで取得できます。
git clone https://github.com/leafony/cad-template.gitライブラリなどの参照先も必要なため、プロジェクトファイルだけでなくフォルダ全体を取得してください。以下のパスに含まれる cad-template は、実際のクローン先またはZIPの展開先に読み替えます。
主なファイル
Section titled “主なファイル”以下は cad-template/KiCad/Leafony_Template/ 内の構成です。
| パス | 用途 |
|---|---|
Leafony_Template.kicad_pro | プロジェクト設定、デザインルール、ネットクラス |
Leafony_Template.kicad_sch | Leafony bus、電源、信号ラベルを配置した回路図 |
Leafony_Template.kicad_pcb | 基板外形、接続部、ビア、銅箔ゾーン禁止領域を含むPCB |
lib/Leafony.kicad_sym | Leafony Bus シンボル |
lib/Leafony.pretty/ | CN_F29_B29 フットプリント |
sym-lib-table | プロジェクト固有のシンボルライブラリ一覧。配布時点では空 |
fp-lib-table | プロジェクト固有のフットプリントライブラリ一覧。Leafony を登録済み |
meta/ | テンプレート名・説明・アイコン・プレビュー画像 |
旧形式の leafony_template-cache.lib、lib/Leafony.dcm、lib/Leafony.bak ではなく、lib/Leafony.kicad_sym をシンボルライブラリとして登録します。.kicad_prl と fp-info-cache は個人設定・キャッシュであり、登録対象ではありません。
ユーザーテンプレートを登録
Section titled “ユーザーテンプレートを登録”- KiCadのプロジェクトマネージャーを起動します。
- 設定 → パスを設定…(Preferences → Configure Paths…) を開きます。OSや表示言語によってメニュー表記は異なります。
KICAD_USER_TEMPLATE_DIRを、取得したリポジトリのKiCadフォルダの絶対パスに設定します。- 設定を保存します。テンプレート一覧に反映されない場合はKiCadを再起動します。
| OS | 設定値の例 |
|---|---|
| Windows | C:/Users/your-name/Documents/cad-template/KiCad |
| macOS | /Users/your-name/Documents/cad-template/KiCad |
| Linux | /home/your-name/cad-template/KiCad |
この変数には、Leafony_Template を含む親フォルダを指定します。設定先の下に Leafony_Template/meta/info.html があることを確認してください。
すでに別のユーザーテンプレートフォルダを使用している場合は、設定値を維持したまま、そのフォルダの下に Leafony_Template を丸ごとコピーしても利用できます。
新規プロジェクトを作成
Section titled “新規プロジェクトを作成”- プロジェクトマネージャーで ファイル → 新規プロジェクト…(File → New Project…) を選びます。
- テンプレート一覧から Leafony Leaf を選びます。必要に応じて一覧をユーザーテンプレートに絞り込みます。
- OK を押し、作業用フォルダと新しいプロジェクト名(例:
my_leaf)を指定します。 - 作成された
my_leaf.kicad_proを開き、回路図とPCBをプロジェクトマネージャーから起動します。
テンプレートのファイルは新しいプロジェクトへコピーされ、主要なファイル名はプロジェクト名に置き換わります。lib フォルダとライブラリ一覧もコピーされます。保存先にはテンプレートの元フォルダとは別の場所を選んでください。
内容を見るだけなら Leafony_Template/Leafony_Template.kicad_pro を直接開けます。自分のリーフを設計するときは、新しく作成したプロジェクトを編集します。
シンボルライブラリを設定
Section titled “シンボルライブラリを設定”作成したプロジェクトの sym-lib-table は、配布時点では空です。配置済みのシンボルは回路図内にも保存されていますが、ライブラリからの追加・参照には登録が必要です。
- プロジェクトマネージャーから回路図エディターを開きます。
- 設定 → シンボルライブラリを管理…(Preferences → Manage Symbol Libraries…) を開きます。
- プロジェクト固有ライブラリ(Project Specific Libraries) を選びます。
- 「既存のライブラリを追加」から、作成したプロジェクト内の
lib/Leafony.kicad_symを選びます。 - 登録内容を次の値に合わせ、有効にして保存します。
| 項目 | 値 |
|---|---|
| ニックネーム | Leafony |
| ライブラリパス | ${KIPRJMOD}/lib/Leafony.kicad_sym |
| ライブラリ形式 | KiCad |
${KIPRJMOD} はKiCadが自動で設定する「現在のプロジェクトフォルダ」です。パス設定画面で追加・変更する必要はありません。
シンボルの選択画面で Leafony:Leafony Bus が表示されることを確認します。既存の CN1 を使う場合、確認のためにもう1個配置する必要はありません。
フットプリントライブラリを確認
Section titled “フットプリントライブラリを確認”fp-lib-table に登録済みのため、通常は追加設定不要です。PCBエディターの 設定 → フットプリントライブラリを管理…(Preferences → Manage Footprint Libraries…) で、プロジェクト固有ライブラリを確認します。
| 項目 | 値 |
|---|---|
| ニックネーム | Leafony |
| ライブラリパス | ${KIPRJMOD}/lib/Leafony.pretty |
| ライブラリ形式 | KiCad |
Leafony:CN_F29_B29 が表示されれば設定できています。再登録する場合は、個別の .kicad_mod ファイルではなく Leafony.pretty フォルダを選びます。
別のPCへ移動・共有するときは、lib フォルダとライブラリ一覧を含むプロジェクト全体をコピーし、${KIPRJMOD} による相対参照を維持してください。
設計を開始する
Section titled “設計を開始する”テンプレートの初期値
Section titled “テンプレートの初期値”以下は収録データの設定値です。基板設定(Board Setup)で層構成、製造上の制約、ネットクラスを確認し、製造先の条件と照合してください。
| 項目 | 初期値 |
|---|---|
| 基板外形 | Edge.Cuts の最大寸法は23 × 20 mm。コネクタ側の幅20 mmに対し、左右に張り出しあり |
| 銅層 | 4層:F.Cu / In1.Cu / In2.Cu / B.Cu |
| 基板厚 | 0.8 mm |
| 接続部 | CN1、表裏各29接点(F1〜F29、B1〜B29) |
| 取り付け穴 | 直径2.05 mmの非めっき穴2個 |
| 最小配線幅・最小クリアランス | 0.1016 mm |
Default ネットクラスの配線幅 | 0.127 mm |
Default ネットクラスのビア径 / ドリル径 | 0.56 mm / 0.30 mm |
コネクタ領域には銅箔ゾーン禁止領域が設定されています。実際の外形・接点位置・穴位置はPCBデータを基準にしてください。
回路・基板を編集する
Section titled “回路・基板を編集する”- 使用するリーフのピン割り当てを確認し、回路図に部品と配線を追加します。Leafony busの接点番号と既存の信号名を確認しながら接続します。
- 追加した部品にフットプリントを割り当て、回路図の電気的ルールチェック(ERC)を実行します。
- ツール → 回路図からPCBを更新…(Tools → Update PCB from Schematic…) でPCBへ反映します。
- 接続部と取り付け穴の位置、他のリーフとの部品干渉を確認し、部品配置・配線を行います。
- 銅箔ゾーンを再充填し、デザインルールチェック(DRC)で未接続や製造ルール違反を確認します。
- ガーバーとドリルファイルを出力し、製造先の指定と照合します。
ピン配置やI2Cアドレスの確認には、自作リーフ開発の資料も参照してください。
よくある問題
Section titled “よくある問題”| 症状 | 確認すること |
|---|---|
Leafony Leaf がテンプレート一覧に出ない | KICAD_USER_TEMPLATE_DIR が Leafony_Template の親フォルダを指し、その下に Leafony_Template/meta/info.html があるか確認します。一覧を開き直すかKiCadを再起動します。 |
| ファイル形式が新しすぎると表示される | KiCad 10.0系で開いているか確認します。 |
Leafony シンボルライブラリが見つからない | 作成したプロジェクトのシンボルライブラリ一覧に Leafony を登録します。配布時の一覧には登録されていません。 |
Leafony:CN_F29_B29 が見つからない | lib/Leafony.pretty と fp-lib-table がプロジェクト内にあり、ニックネームとパスが上記設定と一致しているか確認します。 |
power などの標準シンボルが見つからない | KiCadの標準ライブラリがインストールされ、グローバルライブラリ一覧で有効になっているか確認します。 |
| 別のPCへ移したらライブラリを参照できない | lib フォルダもコピーし、ライブラリのパスが元のPCの絶対パスではなく ${KIPRJMOD} を使用しているか確認します。 |
テンプレートのライセンスはMITです。