AVR MCU:Arduino IDEの設定

このページをAIに渡す

いつものAIとセットアップ

Gemini・その他のAI

質問文をコピーして、いつものAIに貼り付け。キットの確認から動作確認まで、一つずつ進められます。

Geminiを開く

質問文をコピーして、Geminiの入力欄に貼り付けてください。

質問文を確認

目次

Arduino IDEを使って、AP01 AVR MCUリーフ(ATmega328P、3.3 V、8 MHz)の開発環境を設定します。

AZ01C(USB Type-C)を使う書き込みには、手動リセットの操作が必要です。AZ01Cの書き込み手順を参照してください。

用意するもの

  • Basic Kit
  • USBケーブル(データ転送用)
  • パソコン (Windows、macOS 、または Linux)

Arduino IDEのインストール

以下の手順で、Arduino IDEをインストールを行います。。

  1. Arduinoのホームページ からSOFTWAREのページを開きます。
  2. Downloadで、インストーラをダウンロードします。
  3. 画面の指示に従って、インストールします。

Previous IDE インストール

下記より、Previous IDEのインストールができます。

Previous IDE Releases

パソコンと接続

USBケーブルでパソコンを接続します。



マイコンボードの設定

  1. Arduino AVR Boardsは、IDEと一緒にインストールされます。Arduino AVR Boards のバージョンは、ツール→ボード→ボードマネージャ で確認をすることができます。バージョンを選択をすれば、以前のものをインストールすることができます。

  2. ツール → ボードから、Arduino Pro or Pro Miniを選択、プロセッサでATmega328P (3.3V,8MHz)を選択します。



  1. ツール → シリアルポートから、Leafonyが接続されているシリアルポートを選択します。シリアルポートが選択できない場合は、よくある質問を参照してください。


マイコンボードの動作確認

書き込むと、MCUに入っているプログラムが置き換わります。後で購入時のデモを試す場合は、デモの書き戻し方を確認してください。

  1. Arduino IDEを起動し、ファイル → スケッチ例 → 01.Basics → Blinkをクリックし、サンプルアプリを開きます。
  2. マイコンボードに書き込むボタンを押すをAVR MCUリーフにプログラムが書き込まれます。
  3. AVR MCUリーフに搭載されたLEDが点滅していることが確認できれば完了です。

スケッチのピンの指定

ピンは、名前(Name)で指定してください。

ライブラリのインストール

必要なライブラリの配布元、AI04 LCDで使うST7032の選び方、ZIPの導入方法は、ライブラリとボード定義にまとめています。使用するサンプルで指定されたものだけを追加してください。最初のBlinkには追加ライブラリは不要です。

困ったときには

困ったときはよくある質問をお読みください。

リーフ写真
技術資料・サンプル・Q&Aから探せます