ESP32 MCU:Arduino IDEの設定
このページをAIに渡す
目次
Arduino IDEを使って、AP02 ESP32 MCUリーフ(ESP32-WROOM-32)の開発環境を設定します。
用意するもの
- ESP32 Wi-Fi Kit
- USBケーブル(データ転送用)
- パソコン (Windows、macOS 、または Linux)
Arduino IDEのインストール
以下の手順で、Arduino IDEをインストールを行います。
- Arduinoのホームページ
から
SOFTWAREのページを開きます。 Downloadで、インストーラをダウンロードします。- 画面の指示に従って、インストールします。
Previous IDE ダウンロード
下記より、Previous IDEのダウンロードができます。
パソコンと接続
USBケーブルでPCと接続します。

マイコンボードの設定
ボードパッケージの配布URLはEspressif公式の導入手順に従います。サンプルにCoreの版指定がある場合は、その指定を使ってください。
esp32のボードは、webサイトからインストールします。ファイル → 環境設定を開き、追加のボードマネージャのURL:に、下記URLを入力してください。
https://espressif.github.io/arduino-esp32/package_esp32_index.json

-
ツール→ボード→ボードマネージャを選択します。 -
ボードマネージャの検索ボックスに
esp32を入力してインストールします。バージョンを選択ができます。

-
ツール → ボード → ESP32 Dev Moduleをクリックします。 -
ツール → シリアルポートから、Leafonyが接続されているシリアルポートを選択します。シリアルポートが選択できない場合は、よくある質問を参照してください。
マイコンボードの動作確認
書き込むと、MCUに入っているプログラムが置き換わります。後で購入時のデモを試す場合は、デモの書き戻し方を確認してください。
- Arduino IDEを起動し、下記のサンプルコードをコードエディタに貼り付けます。
//*****************************
// ボタン入力の状態をシリアルモニタに表示するサンプル
//*****************************
int pushButton = 0;
void setup() {
Serial.begin(115200);
pinMode(pushButton, INPUT);
}
void loop() {
int buttonState = digitalRead(pushButton);
Serial.println(buttonState);
delay(1);
}
- ESP32 MCUリーフが接続されているシリアルポートを選択します。
マイコンボードに書き込むボタンを押して、スケッチを書き込みます。- 書き込み中に下記の表示が出たら、ESP32リーフの
Bootモードスイッチを長押しします。

- シリアルモニタを開いて、通信速度を
115200bpsにします。 Bootモードスイッチ(IO0)を押してスイッチの入力状態が変わるのを確認します。
スケッチのピンの指定
ピンは、名前(Name)ではなく、ポート(Port)で指定してください。

※1:出力の設定はできません。
※2:WiFi.hをインクルードする場合は、アナログ入力として使用できません。UART1は、ピン番号をRX=26、TX=25に設定です。UART0、2に関しては、ピン番号の指定はありません。下記に、UART1の設定例を記します。
HardwareSerial Serial1(1); // UART1 (RX=9, TX=10)
void setup() {
Serial1.begin(9600, SERIAL_8N1, 26, 25); // ピンを変更 (RX=26, TX=25)
}
※3:ブートストラップに使用しているため、プルアップ禁止です。
ライブラリのインストール
使用するサンプルに必要なものだけを追加します。配布元と導入方法はライブラリとボード定義を参照してください。上のボタン入力の例には追加ライブラリは不要です。
困ったときには
困ったときはよくある質問をお読みください。

