STM32 MCU の Arduino IDE 設定

Arduino IDEでLeafonyにプログラムを書き込む

用意するもの

  • STM32 MCUリーフ
  • Basic Kit
  • パソコン (Windows、Mac OS X 、または Linux)

STM32CubeProg のインストール

プログラムを書き込むには、STM32CubeProgのインストール1が必要です。下記より、インストールしてください。

STM32CubeProg

Arduino IDEのインストール

以下の手順で、Arduino IDEをインストールを行います。

  1. Arduinoのホームページ からSOFTWAREのページを開きます。
  2. Downloadで、インストーラをダウンロードします。
  3. 画面の指示に従って、インストールします。

Previous IDE インストール

下記より、Previous IDEのインストールが出来ます。

Previous IDE Releases

パソコンと接続

USBケーブルでパソコンと接続します。


マイコンボードの設定

  1. Leafony STM32のボードは、webサイトからインストールします。 ファイル → 環境設定を開き、追加のボードマネージャのURL:に、下記URLを入力してください。

    https://github.com/Leafony/BoardManagerFiles/raw/master/test/package_leafony_stm_index.json



  2. ツール→ボード→ボードマネージャを選択します。

  3. ボードマネージャの検索ボックスにLeafonyを入力してインストールします。



  4. ツール → ボード→ Leafony STM32 をクリックします。



  5. ツール → Board part number→ Leafony STM32 MCU をクリックします。



  6. ツール → Upload method→ STM32CubeProgrammer(Serial) をクリックします。



  7. ツール → シリアルポートから、Leafonyが接続されているシリアルポートを選択します。



マイコンボードの動作確認

  1. STM32 MCUリーフのプログラムスイッチを、プログラム側にするとLEDが点灯します。

  2. 温湿度センサ読み取りを参照し、プログラムを書き込みます。正常に書き込まれた場合は Start operation achieved successfullyと表示されます。表示されない場合は、プログラムが正常に動作しません。2

  3. 書き込みが完了したら、STM32 MCUリーフのプログラムスイッチを実行(Run)側にするとLEDが消灯します。

  4. STM32 MCUリーフのリセットスイッチを押してプログラムを動作させます。温度と湿度が表示されていれば完了です。

スケッチのピンの指定

ピンは、名前(Name)又はポート(Port)で指定して下さい。

ライブラリのインストール

プログラムを書き込むには、ライブラリのインストールが必要なリーフがあります。下記より、インストールしてください。

ライブラリのインストール

タイマ割り込みライブラリ(MsTimer2.h)は、AVR MCUのライブラリなので、STM32 MCUリーフには、使用出来ません。以下のHardwareTimerを参考にしてください。

HardwareTimer

使用例を以下に、記載します。詳細はこちら

初期設定

HardwareTimer *timer2 = new HardwareTimer (TIM2);

  timer2->setOverflow(LOOP_INTERVAL, MICROSEC_FORMAT);       // 125ms
  timer2->attachInterrupt(intTimer);
  timer2->resume();

割り込みルーチン

void intTimer(void){
  bInterval = true;
 
 
}

困ったときには

お問い合わせをする前に、困ったときにはを読んでみてください。

前のページに戻る


  1. Windows 64bitのV2.6.0とV2.4.0は動作確認済みですが、v2.5.0は動作しません。 ↩︎

  2. スイッチをプログラム側にしないで書き込んだ場合もボードへの書き込みが完了しましたとなりますが、画面の下部にTimeout error occured while waiting for acknowledgementと表示され、プログラムが正常に動作しません。

     ↩︎

最終更新 June 24, 2021